CRAN Package Check Results for Package manhattanly

Last updated on 2020-08-13 15:51:10 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.2.0 0.88 2.72 3.60 ERROR
r-devel-linux-x86_64-debian-gcc 0.2.0 5.74 44.13 49.87 OK
r-devel-linux-x86_64-fedora-clang 0.2.0 83.42 NOTE
r-devel-linux-x86_64-fedora-gcc 0.2.0 75.27 OK
r-devel-windows-ix86+x86_64 0.2.0 25.00 85.00 110.00 OK
r-patched-linux-x86_64 0.2.0 7.02 55.84 62.86 OK
r-patched-solaris-x86 0.2.0 102.20 WARN
r-release-linux-x86_64 0.2.0 6.33 56.43 62.76 OK
r-release-macos-x86_64 0.2.0 WARN
r-release-windows-ix86+x86_64 0.2.0 23.00 73.00 96.00 OK
r-oldrel-macos-x86_64 0.2.0 WARN
r-oldrel-windows-ix86+x86_64 0.2.0 15.00 68.00 83.00 OK

Check Details

Version: 0.2.0
Check: package dependencies
Result: ERROR
    Package required but not available: 'plotly'
    
    See section 'The DESCRIPTION file' in the 'Writing R Extensions'
    manual.
Flavor: r-devel-linux-x86_64-debian-clang

Version: 0.2.0
Check: Rd cross-references
Result: NOTE
    Undeclared package ‘qqman’ in Rd xrefs
Flavor: r-devel-linux-x86_64-fedora-clang

Version: 0.2.0
Check: re-building of vignette outputs
Result: WARN
    Error(s) in re-building vignettes:
     ...
    --- re-building ‘manhattanly.Rmd’ using rmarkdown
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) and/or pandoc-citeproc not available. Falling back to R Markdown v1.
    Loading required package: ggplot2
    
    Attaching package: 'plotly'
    
    The following object is masked from 'package:ggplot2':
    
     last_plot
    
    The following object is masked from 'package:stats':
    
     filter
    
    The following object is masked from 'package:graphics':
    
     layout
    
    Warning: `arrange_()` is deprecated as of dplyr 0.7.0.
    Please use `arrange()` instead.
    See vignette('programming') for more help
    This warning is displayed once every 8 hours.
    Call `lifecycle::last_warnings()` to see where this warning was generated.
    Quitting from lines 95-96 (manhattanly.Rmd)
    Error: processing vignette 'manhattanly.Rmd' failed with diagnostics:
    there is no package called 'webshot'
    --- failed re-building ‘manhattanly.Rmd’
    
    SUMMARY: processing the following file failed:
     ‘manhattanly.Rmd’
    
    Error: Vignette re-building failed.
    Execution halted
Flavor: r-patched-solaris-x86

Version: 0.2.0
Check: re-building of vignette outputs
Result: WARN
    Error(s) in re-building vignettes:
    --- re-building ‘manhattanly.Rmd’ using rmarkdown
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) and/or pandoc-citeproc not available. Falling back to R Markdown v1.
    Loading required package: ggplot2
    
    Attaching package: 'plotly'
    
    The following object is masked from 'package:ggplot2':
    
     last_plot
    
    The following object is masked from 'package:stats':
    
     filter
    
    The following object is masked from 'package:graphics':
    
     layout
    
    Warning: `arrange_()` is deprecated as of dplyr 0.7.0.
    Please use `arrange()` instead.
    See vignette('programming') for more help
    This warning is displayed once every 8 hours.
    Call `lifecycle::last_warnings()` to see where this warning was generated.
    PhantomJS not found. You can install it with webshot::install_phantomjs(). If it is installed, please make sure the phantomjs executable can be found via the PATH variable.
    Warning in normalizePath(f2) :
     path[1]="webshot28ed604f0649.png": No such file or directory
    Warning in file(con, "rb") :
     cannot open file 'webshot28ed604f0649.png': No such file or directory
    Quitting from lines 95-96 (manhattanly.Rmd)
    Error: processing vignette 'manhattanly.Rmd' failed with diagnostics:
    cannot open the connection
    --- failed re-building ‘manhattanly.Rmd’
    
    SUMMARY: processing the following file failed:
     ‘manhattanly.Rmd’
    
    Error: Vignette re-building failed.
    Execution halted
Flavor: r-release-macos-x86_64

Version: 0.2.0
Check: re-building of vignette outputs
Result: WARN
    Error(s) in re-building vignettes:
    --- re-building ‘manhattanly.Rmd’ using rmarkdown
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) and/or pandoc-citeproc not available. Falling back to R Markdown v1.
    Loading required package: ggplot2
    
    Attaching package: 'plotly'
    
    The following object is masked from 'package:ggplot2':
    
     last_plot
    
    The following object is masked from 'package:stats':
    
     filter
    
    The following object is masked from 'package:graphics':
    
     layout
    
    PhantomJS not found. You can install it with webshot::install_phantomjs(). If it is installed, please make sure the phantomjs executable can be found via the PATH variable.
    Warning in normalizePath(f2) :
     path[1]="webshotd4a14dcd902a.png": No such file or directory
    Warning in file(con, "rb") :
     cannot open file 'webshotd4a14dcd902a.png': No such file or directory
    Quitting from lines 95-96 (manhattanly.Rmd)
    Error: processing vignette 'manhattanly.Rmd' failed with diagnostics:
    cannot open the connection
    --- failed re-building ‘manhattanly.Rmd’
    
    SUMMARY: processing the following file failed:
     ‘manhattanly.Rmd’
    
    Error: Vignette re-building failed.
    Execution halted
Flavor: r-oldrel-macos-x86_64